This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.
Incident Summary
Description: We identified an issue for Hybrid Deployment Agents which resulted in syncs failing with a “Connection pool shut down" error.
Timeline: This issue began on May 29, 2026 at 14:10 UTC UTC and was resolved on May 29, 2026 at 23:36 UTC.
Cause: A software update introduced a defect in the way Hybrid Deployment Agents managed connections to the underlying container runtime (specifically Docker or Podman). Under certain conditions, the HD Agent attempted to replace an invalid connection, but some internal components continued using references to the original closed connection. This prevented affected agents from starting new sync jobs.
Resolution: Fivetran reverted the software change that introduced the issue, deployed a corrected agent version, and remotely updated all affected agents. Following the update, normal sync operations resumed without requiring customer intervention.
Posted May 29, 2026 - 23:59 UTC
Monitoring
We are monitoring the results of the fix. Customers are advised to restart their HD agents.
Posted May 29, 2026 - 21:44 UTC
Update
The hot fix should be reflected in the new HD agent images. For existing HD agents, restarting the controller should resolve the issue. Customers are advised to restart their controller with the following commands:
cd ~/fivetran ./hdagent.sh stop ./hdagent.sh start
Posted May 29, 2026 - 21:30 UTC
Update
We have identified the root cause and have deployed a hot fix.
Posted May 29, 2026 - 20:32 UTC
Identified
The Fivetran Hybrid Deployment Agent is experiencing an issue that may cause syncs to fail to start or connections to fail during setup tests and syncs. HD agent logs show the following error "Return CreateJobResponse/Failure, Caused By User: false - CREATE_JOB_ERROR/Connection pool shut down {process_id=XXX}"
This issue only affects HD deployments in Docker/Podman environments.
Posted May 29, 2026 - 16:40 UTC
This incident affected: Systems (General Services).