Fivetran: Facebook Ads connections are failing with a Metric Definition Exception

Incident Report for Fivetran

Resolved

This incident has been resolved. We have confirmed that instance rates have returned to normal, and Facebook Ads connections are now syncing successfully.

Incident Summary
Description:
Facebook Ads connections were failing with a Metric Definition Exception.

Timeline:
The issue began on October 22, 2025, at 15:36 UTC and was resolved at 18:19 UTC.

Cause:
The sync failures occurred due to a recent code change introduced as part of a connector enhancement.

Resolution:
A Hotfix was deployed to address the issue by modifying the code logic. Following the deployment, affected connections resumed syncing successfully.
Posted Oct 22, 2025 - 19:23 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Oct 22, 2025 - 18:23 UTC

Identified

We have identified that the connection syncs are failing with the following error, and we are working to resolve it:

"Cannot use metric definition of type interface io.micrometer.core.instrument.Timer to create metric of type interface io.micrometer.core.instrument.LongTaskTimer"
Posted Oct 22, 2025 - 16:45 UTC
This incident affected: Marketing connectors (Facebook Ads).