3rd Party: Twitter and Twitter Ads connections are failing with "HTTP 503 Service Unavailable" error

Incident Report for Fivetran

Update

There are no updates from Twitter on their status page: https://docs.x.com/status

We are looking into potential workarounds to address these failures and will provide further updates as soon as more information is available.
Posted Apr 10, 2026 - 06:09 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Apr 10, 2026 - 04:15 UTC
This incident affects: Marketing connectors (Twitter Ads).