Description: Multiple Shopify connections are failing with a NullPointerException
Timeline: 2025-10-02 12:54 UTC to 2025-10-03 2:36 UTC
Cause: Shopify started providing null instead of an empty array for the list orders_to_redact.
Resolution: Shopify's Customer redact Order Delete warning were skipped for affected customers, and we are now adding the safety null check to handle bad source data and we will be covering the missed dashboard warnings from yesterday.
Posted Oct 03, 2025 - 08:15 UTC
Update
Syncs are now running successfully, and there have been no failures in the last hour. We will share the RCA soon.
Posted Oct 03, 2025 - 04:16 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 03, 2025 - 02:58 UTC
Update
We have created a fix for this issue, and the fix is currently being deployed.
Posted Oct 03, 2025 - 01:54 UTC
Update
We have identified an issue causing many of our Shopify Connections to fail with the error:
Failed to sync 1 endpoint: - Deleted Events: Cannot invoke "java.util.List.iterator()" because "order.orders_to_redact" is null.
Our team is working to resolve this issue.
Posted Oct 02, 2025 - 18:04 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Oct 02, 2025 - 17:55 UTC
This incident affected: Sales connectors (Shopify).