3rd Party: Amazon Ads Connectors are failing with "HTTP 503 Service Temporarily Unavailable"

Incident Report for Fivetran

Resolved

The connectors have returned to their normal functionality with most of the connectors completing successful syncs. The incident has been resolved.
Posted Jul 31, 2024 - 12:12 UTC

Monitoring

Connectors are recovering from the 503 errors and completing syncs successfully.

We will continue to monitor the remaining connectors until they resume their normal sync functionality.
Posted Jul 31, 2024 - 08:52 UTC

Update

The sync failures have occurred because of third-party source issues. Amazon Ads has acknowledged this issue on their status page: https://status.ads.amazon.com/. We are closely monitoring the connectors.
Posted Jul 31, 2024 - 05:52 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Jul 31, 2024 - 04:57 UTC
This incident affected: Marketing connectors (Amazon Ads).