Pardot Connectors Failing
Incident Report for Fivetran
Postmortem

Incident Cause:

Pardot added a new custom field is_analytics_synced in the api response of /api/customField/version/3/do/query . This caused parsing errors and resulted in “Unrecognized field is_analytics_synced" error.

Incident Date(s):

Reported:  Feb 06, 2021 - 12:33 UTC

Identified : Feb 06, 2021 - 13:01 UTC

Fixed : Feb 06, 2021 - 13:36 UTC

Resolved:  Feb 06, 2021 - 15:57 UTC

Incident Resolution:

Fix was deployed to Ignore unknown fields from API response.

Posted Feb 16, 2021 - 03:48 UTC

Resolved
Connectors are up and running fine now. Marking the incident solved. We will publish the RCA report at the earliest.
Posted Feb 06, 2021 - 15:57 UTC
Monitoring
A fix has been implemented and we are seeing connectors are up and running. We will continue to monitor.
Posted Feb 06, 2021 - 13:36 UTC
Identified
The issue has been identified and a fix is being implemented. The fix is to skip the unrecognised field.
Posted Feb 06, 2021 - 13:01 UTC
Investigating
All Pardot connectors are failing due to an Unrecognized field "is_analytics_synced". We are currently investigating this issue.
Posted Feb 06, 2021 - 12:33 UTC
This incident affected: Fivetran Services (Replication Servers).