Multiple Twitter Ads and Twitter Organic Connections Failing with error "HTTP 503 Service Unavailable"

Incident Report for Fivetran

Update

The issue appears to be related to missing rate limit headers in the response. As a result, requests are repeatedly hitting HTTP 429 (rate limit) and, in some cases, resulting in HTTP 503 errors. We have reached out to X support, and X has also acknowledged degraded performance on their status page: https://docs.x.com/status
Posted Mar 30, 2026 - 18:09 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Mar 30, 2026 - 17:55 UTC
This incident affects: Marketing connectors (Twitter Organic, Twitter Ads).