Fivetran: Some facebook_ads connector are failing with an error like "Null primary key found while syncing table"

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.

Incident Summary
Description:
We identified an issue for facebook_ads that caused syncs to fail with a "Null primary key found while syncing table" error.

Timeline:
This issue began on 12.02.2025 at 21:00:00 UTC and was resolved on 15.02.2025 at 03:00:00 UTC.

Cause:
Connectors were failing due to missing breakdown values in the Facebook API. This caused the date integrity issue, which in turn caused sync failure.

Resolution:
We implemented a workaround by skipping accounts with missing breakdown data and displaying a warning message to notify customers in such cases.
Posted Feb 15, 2025 - 03:31 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 15, 2025 - 02:28 UTC

Update

We are continuing to work on a fix for this issue.
Posted Feb 15, 2025 - 00:36 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Feb 14, 2025 - 19:15 UTC
This incident affected: Marketing connectors (Facebook Ads).