This incident has been resolved. We have observed that instance rates are returning to normal levels, and affected connections are syncing successfully.
Incident Summary
Description: We identified an issue with the Pardot connections, which resulted in syncs failing with a 'IllegalArgumentException Unrecognized type LocalTime' error.
Timeline: This issue began on January 8th, at around 17:00 UTC and was resolved on January 10th, at around 1:20 UTC.
Cause: The incident was triggered by the rollout of the ENGAGEMENT_STUDIO_PROGRAM table, on 2026-01-07, as a result of which we tried to write an incompatible data type, LocalTime, to the destination. Consequently, the connectors failed during flush operations due to this.
Resolution: Service was restored by pausing the rollout of the feature. A permanent fix has been submitted to transition the data mapping from LocalTime to String. The rollout of the ENGAGEMENT_STUDIO_PROGRAM table will be resumed in the upcoming days.
Posted Jan 10, 2026 - 14:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 10, 2026 - 14:00 UTC
Update
We have identified a data type mismatch affecting the Pardot connector. An incompatible LocalTime definition in the engagement_studio_program table introduced via a rollout on January 6 is currently unsupported by the BigQuery writer, leading to failure rate.
We are working on a hotfix to address the IllegalArgumentException and resolve the issue.
Posted Jan 10, 2026 - 10:28 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 10, 2026 - 10:25 UTC
This incident affected: Marketing connectors (Pardot).