3rd Party: Facebook Ads connectors are failing with "Unable to fetch the data for single entity" exception
Incident Report for Fivetran
Resolved
This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.

Incident Summary
Description:
We identified an issue for Facebook ads that resulted in syncs failing with the error "Unable to fetch the data for single entity" exception

Timeline:
This issue began on October 22, 2024, at 15:20 UTC and was resolved on October 24, 2024, at 00:12 UTC.

Cause:
We identified two problematic fields - "bundle_folder_id" and "dynamic_ad_voice" that was causing this error while fetching data for `creative_history` table.

Resolution:
We deployed a fix to avoid further sync failures.
Posted Oct 24, 2024 - 07:49 UTC
Monitoring
A fix has been implemented, and we are monitoring the results.
Posted Oct 24, 2024 - 00:44 UTC
Update
We have identified two problematic fields from the Facebook API that are leading to these failures.

A hot fix is currently being deployed to avoid further sync failures. We will monitor for any further failures once the deployment completes.
Posted Oct 23, 2024 - 22:59 UTC
Update
We have identified that syncs are failing while the connector attempts to fetch data for the Creative entity. We will continue to investigate and provide further updates.
Posted Oct 23, 2024 - 21:26 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Oct 23, 2024 - 20:25 UTC
This incident affected: Marketing connectors (Facebook Ads).