Qualtrics connector failing with "400 bad request"
Incident Report for Fivetran
Resolved
This incident has been resolved.
Posted Apr 21, 2021 - 10:37 UTC
Monitoring
The fix has been deployed and the connectors are running successfully. We will continue to monitor the syncs.
Posted Apr 21, 2021 - 08:10 UTC
Identified
We are implementing a temporary fix to ignore "400 Bad Request" error. Once the issue is fixed on Qualtrics side, we will automatically backfill the records on this endpoint.
Posted Apr 21, 2021 - 06:00 UTC
Update
Qualtrics team updated that the issue seems to be with the Group ID's returned on the messages endpoint. We are working with them to investigate further.
Posted Apr 21, 2021 - 02:58 UTC
Update
Our engineering team is working with Qualtrics development team to find the root cause. Qualtrics support is investigating their API to help find the root cause.
Posted Apr 20, 2021 - 18:00 UTC
Investigating
We've identified an issue with Qualtrics API calls returning 400 bad request when we attempt to call this endpoint:

https://fra1.qualtrics.com/API/v3/libraries/[ID number]/messages

Our engineering team is investigating the cause now.
Posted Apr 20, 2021 - 16:39 UTC
This incident affected: Replication Servers.