This incident has been resolved. We have observed that instance rates are returning to normal levels, and affected connections are syncing successfully.
Incident Summary Description: We identified an issue in which Apple Search Ads connections were failing with the error "HTTP 400 Bad Request."
Timeline: This issue began on June 18, 2026, at 17:47 UTC and was resolved on June 19, 2026, at 11:02 UTC.
Cause: The issue was caused by a recent code change that introduced an unexpected error in Apple Search Ads connection processing.
Resolution: Identified the problematic change and reverted it Following the change, affected Apple Search Ads connections resumed normal operation and the issue was fully resolved.
Posted Jun 19, 2026 - 10:43 UTC
Monitoring
A hotfix has been deployed, and the syncs are recovering. We will continue monitoring the syncs
Next Expected Update: 3 hours
Posted Jun 19, 2026 - 08:30 UTC
Update
We have identified that this issue was caused by a recent change, and we are currently working on reverting the changes via a hotfix.
Next Expected Update: 2 hours
Posted Jun 19, 2026 - 06:45 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Jun 19, 2026 - 06:15 UTC
This incident affected: Marketing connectors (Apple Search Ads).