Fivetran: MDLS destinations with Azure Storage were experiencing connection failures

Incident Report for Fivetran

Resolved

Description:
Multiple MDLS destinations with Azure storage were experiencing failure in connections and syncs. The error observed was:

Unable to process: Failed to get subscoped credentials: DefaultAzureCredential authentication failed

Timeline:
This issue began on 22/09/2025, at 02:30 UTC
Resolved on 22/09/2025, at 07:10 UTC

Cause:
Service communication with Azure destination storage was disrupted due to authentication service connectivity issues. This prevented Fivetran from establishing connections and performing sync operations.

Resolution:
Authentication configuration was restored, and the affected services were restarted to resume normal operations.
Posted Sep 22, 2025 - 03:00 UTC