3rd Party: Some HubSpot connections intermittently failing with "The requested resource does not exist" error

Incident Report for Fivetran

Resolved

This incident has been resolved. We observed connector sync success rates returning to normal levels, and HubSpot connector syncs are now running as expected.

Incident Summary:
Description:
We identified an issue where HubSpot connector syncs were failing with the error:
Endpoint [marketing_email] encountered an exception: "The requested resource does not exist."

Timeline:
The issue began on March 5, 2026, at 10:30 AM UTC and was resolved at 12:10 PM UTC.

Cause:
The issue was caused by a third-party outage on HubSpot's infrastructure.
HubSpot status page: https://status.hubspot.com/incidents/9szm40l2fq2s

Resolution:
HubSpot identified and resolved the issue on their end. No changes were required on our side.
Posted Mar 05, 2026 - 13:29 UTC

Monitoring

HubSpot has resolved the issue, and we are currently monitoring the results to ensure sync operations continue to run as expected.
Posted Mar 05, 2026 - 12:50 UTC

Update

The issue has been identified as a HubSpot outage that caused temporary unavailability of certain API services. As a result, affected connections experienced intermittent sync failures.

HubSpot has implemented a fix, and services are currently recovering.

For additional details, please refer to the HubSpot Status Page:
https://status.hubspot.com/incidents/9szm40l2fq2s
Posted Mar 05, 2026 - 12:31 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Mar 05, 2026 - 12:10 UTC
This incident affected: Sales connectors (HubSpot).