Twitter Connectors are Delayed
Incident Report for Fivetran Inc
Resolved
This incident has been resolved.
Posted Dec 17, 2020 - 10:18 UTC
Update
Connectors which have relatively less data have come back to normal sync speeds. But it appears that some of the larger ones are still taking quite some time to sync as the jobs processing time has reduced but not reduced till the previous values
Posted Dec 17, 2020 - 04:25 UTC
Monitoring
Twitter's team has worked on this issue and the sync times are getting back to normal - https://twittercommunity.com/t/announcement-asynchronous-analytics-service-issues/146965

We will continue monitoring this until all the connectors are up and running as expected.
Posted Dec 15, 2020 - 05:12 UTC
Update
Job completion on Twitter's API is delayed - the time to completion has increased from a few seconds to minutes. This seems to be a widespread issue with Twitter and we have reached out to Twitter about this - https://twittercommunity.com/t/async-analytics-takes-forever-to-complete/146945/5
Posted Dec 14, 2020 - 11:29 UTC
Investigating
The sync duration of Twitter connectors seem to be longer than usual since Dec 11, 2020. Our engineering team is looking into this.
Posted Dec 14, 2020 - 10:26 UTC
This incident affected: Fivetran Services (Replication Servers).