Fivetran: Fivetran REST API calls to Connection endpoint may fail with "500 Server Error"

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.

Incident Summary
Description:
We identified an issue where REST API calls to the Fivetran Connection endpoint resulted in "500 Server Error" failures for a small number of customers.

Timeline:
This issue began on Sept 25 at 10:00 UTC and was resolved on Sept 25 at 23:37 UTC.

Cause:
This issue was caused by a bug introduced in a recent code change.

Resolution:
We resolved the issue by deploying a code hotfix.
Posted Sep 26, 2025 - 00:20 UTC

Monitoring

A fix has been deployed to production and we are currently monitoring it.
Posted Sep 25, 2025 - 23:50 UTC

Update

Fivetran Engineering is still actively testing fixes for this issue.
Posted Sep 25, 2025 - 23:41 UTC

Identified

Customers making REST API calls to Fivetran Connection endpoint, i.e.,
https://api.fivetran.com/v1/connections/connectionId
may experience "Server 500 Error" failures.

We have identified the source of the issue and are currently implementing a fix.
Posted Sep 25, 2025 - 21:05 UTC
This incident affected: Fivetran API.