Tiktok Ads connector failing with the error “System maintenance”
Incident Report for Fivetran
Resolved
We have resolved this incident.
Posted Oct 15, 2021 - 02:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 15, 2021 - 02:36 UTC
Update
We are continuing to see TikTok Ads connectors failing with 'System maintenance' error messages.

This has been identified as a limitation on the time ranges that Fivetran can query from the TikTok API. We are working with our TikTok contacts to restore access and reduce the size of queries.
Posted Oct 14, 2021 - 20:50 UTC
Update
We are continuing to see TikTok Ads connectors failing with 'System maintenance.' error messages when attempting to retrieve data from the TikTok Ads API. We received a report from TikTok that our API calls are failing when requesting larger data sets, and Fivetran has been investigating the size of the data that we request.

We have an open ticket #346090 with Tiktok Support, and this is currently being investigated by the TikTok team. We are requesting your help to escalate this issue with Tiktok to gain traction towards a quicker resolution.
Posted Oct 14, 2021 - 16:42 UTC
Update
We are continuing to see TikTok Ads connectors failing with 'System maintenance.' error messages when attempting to retrieve data from the TikTok Ads API.

The initial response from Tiktok states that API call is failing because of a big data load while requesting more than 1-day data. Fivetran team investigated and found the API is also failing for 1-day report data.

We have an open ticket #346090 with Tiktok Support and it is currently being investigated by the Tiktok team.

We are requesting your help to escalate this issue with Tiktok to gain traction towards a quicker resolution.
Posted Oct 14, 2021 - 09:53 UTC
Update
We are continuing to see TikTok Ads connectors failing with "java.lang.RuntimeException: 'System maintenance.'" error messages when attempting to retrieve data from the TikTok Ads API.

We are continuing to investigate this issue, and we have reached out to TikTok for more information on this issue. We will have more information as soon as we have a response.
Posted Oct 13, 2021 - 23:35 UTC
Update
TikTok Ads connectors are failing with a "java.lang.RuntimeException: 'System maintenance.'" error message after attempting to retrieve data from the TikTok Ads API.

We are continuing to investigate this issue and we have reached out to TikTok for more information on this system maintenance.
Posted Oct 13, 2021 - 20:29 UTC
Update
Connectors are still failing while attempting to access the TikTok Ads endpoint with an error message indicating system maintenance on the TikTok side.

We're still investigating this issue, and we've reached out to TikTok for more information.
Posted Oct 13, 2021 - 18:34 UTC
Update
Connectors are failing while accessing the API endpoint https://business-api.tiktok.com/open_api/v1.2/reports/integrated/get/.

We are still investigating the issue and reached out to the Tiktok support to gain some insights into the error.
Posted Oct 13, 2021 - 10:27 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Oct 13, 2021 - 06:57 UTC
This incident affected: Connectors (Marketing).