MySQL connectors failing with java.lang.AssertionError
Incident Report for Fivetran
Resolved
All connectors have now recovered.
Posted Oct 22, 2021 - 22:52 UTC
Monitoring
The fix is deployed and we're seeing connectors recover for syncs starting later than 12:30pm PDT.

We will continue to monitor for any unexpected failures with this error.
Posted Oct 22, 2021 - 19:41 UTC
Update
The fix has passed the QA process and we are starting the deploy to production. Current ETA for having this fix deployed is 1:30 PM PDT.
Posted Oct 22, 2021 - 17:18 UTC
Update
The fix is developed and is going through our QA process now. Once all tests pass we'll begin deploying to production.
Posted Oct 22, 2021 - 16:25 UTC
Update
We've identified that the source of the issue is related to the parsing of binlog events.

We are currently working on a fix to address it.
Posted Oct 22, 2021 - 12:03 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Oct 22, 2021 - 10:57 UTC