3rd Party: Multiple Twitter and Twitter Ads connections are failing with "HTTP 503 Service Unavailable"

Incident Report for Fivetran

Update

We have reached out to the third-party to obtain the latest status on this issue and are currently awaiting their response.

Additionally, we have started observing "HTTP 500 – Internal Server Error" for a few connections.

At this time, there are no further updates available on their status page. We are continuing to closely monitor the situation and will share updates as soon as we receive more information.
Posted Mar 26, 2026 - 08:35 UTC

Update

The third-party is still working on this incident, and there have been no further updates on their status page at this time.

We are continuing to closely monitor the situation and will keep you informed as soon as we receive any new information.
Posted Mar 26, 2026 - 05:56 UTC

Update

The issue has been identified as being caused by a problem on the third-party side. They have also acknowledged and posted an update on their page (link below).

https://docs.x.com/status

We are closely monitoring the situation and will provide further updates as soon as more information becomes available.
Posted Mar 26, 2026 - 04:09 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Mar 26, 2026 - 03:30 UTC
This incident affects: Marketing connectors (Twitter Ads).