Fivetran: Fivetran Platform connector providing incorrect/missing data for incremental_mar table

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that connectors have resumed their normal sync functionality
Posted Jul 19, 2024 - 13:47 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2024 - 16:00 UTC

Update

We have identified the issue, and our engineering team has already worked on the fix. Currently, it is being tested internally. Once the validation is complete we will roll out the fix for all the affected connectors.
Posted Jul 16, 2024 - 18:22 UTC

Update

Summary of the issue:

The new column connector_id, designated as the primary key, altered the calculation, resulting in the removal of a significant amount of data from the incremental_mar table on the destination side. The Fivetran Engineering team is currently working on a fix for this.
Posted Jul 16, 2024 - 06:43 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Jul 16, 2024 - 06:17 UTC
This incident affected: Log connectors (Fivetran Platform).