The fix has restored normal functionality to all affected connectors, and the incident is now resolved.
Posted Jul 11, 2024 - 08:45 UTC
Monitoring
We have implemented a fix to address the error, and the affected connectors are beginning to sync. We will continue to monitor all affected connectors until they fully resume normal sync functionality.
Posted Jul 11, 2024 - 05:47 UTC
Update
We've identified a problem with the hash calculation for primary key-less tables. In our process, we use Snowflake's CONCAT_WS() function, which concatenates columns with a specified delimiter. However, we've discovered that the connectors are failing because the function expects a list of columns, but an empty list is being passed instead. This mismatch is causing the failure; we will update you as the fix is raised.
Posted Jul 10, 2024 - 11:35 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Jul 10, 2024 - 08:52 UTC
This incident affected: Database connectors (Snowflake).