Fivetran: Snowflake destinations failing with error code 503
Incident Report for Fivetran
Resolved
This incident has been resolved. We have observed that error rates are returning to normal levels, and affected connectors are syncing successfully.

Incident Summary
Description:
We identified an issue for Snowflake destinations, which resulted in syncs failing with a "JDBC driver encountered communication error. Message: HTTP status=503." error.

Timeline:
This issue began on 2024-09-03 at 3:11 PM UTC and was resolved on 2024-09-04 at 11:00 AM UTC.

Cause:
Upgrading the Snowflake JDBC driver caused a number of connectors to fail intermittently or constantly, particularly in destinations containing a large number of connectors syncing simultaneously.

Resolution:
Downgrading the driver allowed affected connectors to resume operating normally. We will work with Snowflake to identify the root cause of the issue and address it before performing this upgrade again.
Posted Sep 04, 2024 - 12:57 UTC
Monitoring
We reverted the Snowflake driver to its previous version and are monitoring the connectors to ensure the errors are subsiding.
Posted Sep 04, 2024 - 10:54 UTC
Update
We identified an issue caused by an upgrade of our Snowflake JDBC drivers.
Affected connectors are failing with the error "JDBC driver encountered communication error. Message: HTTP status=503.".
We are working on reverting the upgrade and will deploy the change shortly.
Posted Sep 04, 2024 - 09:15 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Sep 04, 2024 - 09:12 UTC
This incident affected: Systems (Destinations).