MySQL - Connectors failing when reconnecting to binlogs
Incident Report for Fivetran
Resolved
This incident has been resolved and all connectors should now be functional.
Posted Feb 13, 2021 - 05:11 UTC
Monitoring
The rollback was completed at about 3:30pm PDT.

You may need to pause and unpause your connector to have the sync succeed. We will monitor and look into connectors still receiving this error at the end of today.
Posted Feb 12, 2021 - 23:41 UTC
Identified
We've identified a recent change to the disconnect behavior which is causing reconnects to binlogs to throw the following error a subset of MySQL connector users:

"ServerException: A slave with the same server_uuid/server_id as this slave has connected to the master;"

Fivetran engineering is rolling back the change now. We're currently targeting 3pm PDT to complete the rollback.
Posted Feb 12, 2021 - 20:18 UTC
This incident affected: Fivetran Services (Replication Servers).