This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.
Incident Summary Description: We identified an issue for HubSpot that resulted in syncs failing with error code 1006.
Timeline: This issue began on Oct 21, 2024 at 23:35 UTC and was resolved on Oct 22, 2024 at 19:54 UTC.
Cause: HubSpot blocked some of our IPs for a couple of regions. Their team informed us that the issue stemmed from some JavaScript code being passed while fetching data for the *_analytics_*_report table.
Resolution: We deployed a temporary workaround to disable *_analytics_*_report table for the connectors. This helped us get our IPs unblocked and the syncs succeeded. We are working on a permanent fix so we can re-enable the sync for the skipped tables.
Posted Oct 22, 2024 - 19:54 UTC
Update
We are continuing to monitor the connectors.
Posted Oct 22, 2024 - 15:56 UTC
Monitoring
Hubspot support has unblocked the IPs, and connectors are not failing anymore. We are monitoring the connectors.
Posted Oct 22, 2024 - 12:35 UTC
Update
Hotfix to disable *_analytics_*_report table is being deployed. We are waiting for Hubspot Support to unblock the IPs.
Posted Oct 22, 2024 - 10:14 UTC
Update
HubSpot has blocked additional IPs in the gcp/europe-west3 and gcp/us-east4 regions. Hubspot support informed us that the issue stems from some JavaScript code being passed while fetching data for the *_analytics table, which triggered the IP blocking. We are working on the fix to address this issue.
Posted Oct 22, 2024 - 06:50 UTC
Identified
We have identified additional HubSpot connectors experiencing sync failure with error code 1006. HubSpot is blocking some Fivetran IP addresses. We have contacted HubSpot Support to have Fivetran IPs unblocked.
Posted Oct 21, 2024 - 23:35 UTC
This incident affected: Sales connectors (HubSpot).