Fivetran: Some Marketo connectors are experiencing elongated and failed syncs when extracting program_membership data
Incident Report for Fivetran
Resolved
This incident has been resolved. We have observed that instance rates have returned to normal levels and affected connectors are syncing successfully.
Posted May 14, 2024 - 18:13 UTC
Monitoring
We have deployed an additional code change to retry failing API calls for the program_membership table. Incidence rates are falling after the retry was introduced and we are currently monitoring all affected connectors.
Posted May 14, 2024 - 08:05 UTC
Identified
The hotfix has allowed affected connectors to resume their normal sync functionality but we continue to observe intermittent API errors when querying for program_membership data. When these errors occur, we skip the syncing of program_membership data to allow all other selected tables to be updated.

We have contacted Marketo regarding this behavior and will provide additional updates accordingly.
Posted May 14, 2024 - 07:00 UTC
Monitoring
A hotfix has been deployed to address the sync failures and delayed syncs. We will continue monitoring to ensure that all connectors recover successfully.
Posted May 10, 2024 - 21:07 UTC
Update
We have identified that API calls used to fetch program_membership data are failing periodically with a "startAt/ endAt are not valid" error. We are preparing sync improvements to handle these intermittent API errors in order to prevent further sync failures.

Additionally, the historical sync timeframe was unintentionally extended with the introduction of the Priority-first Sync strategy for the program_membership table. We will be stopping the sync of additional historical program_membership data in order to resolve the sync delays.
Posted May 10, 2024 - 17:12 UTC
Identified
We have identified an issue where some Marketo connectors are experiencing elongated and failed syncs when extracting program_membership data. We are currently investigating in more detail and will provide additional updates accordingly.
Posted May 10, 2024 - 13:33 UTC
This incident affected: Marketing connectors (Marketo).