Pinterest Ads Connectors are failing
Incident Report for Fivetran Inc
Resolved
This incident has been resolved.
Posted Jul 23, 2020 - 14:17 UTC
Monitoring
We were finally able to get in touch with Pinterest and get this issue fixed. We are continuing to monitor the connectors to verify successful resolution.
Posted Jul 21, 2020 - 13:05 UTC
Update
As a temporary fix, we are skipping the Pins endpoint until we get a long term resolution from Pinterest's side.
Posted Jul 16, 2020 - 16:46 UTC
Update
While we are awaiting a further update from Pinterest Support, it would be helpful if our customers using the Pinterest Ads Connector can assist and also reach out to Pinterest Support about this ongoing issue. It would greatly help expedite the issue to resolution.
Posted Jul 10, 2020 - 20:58 UTC
Update
We are still waiting for to hear from Pinterest about the resolution of this error on their end.
Posted Jul 10, 2020 - 13:48 UTC
Identified
Pinterest Ads Connectors are currently failing on the (/pins) endpoint. We're receiving the following error/response from the Pinterest API:

"Unsuccessful API call. Message: Something went wrong on our end. Sorry about that. null"

Fivetran Development Team has reached out to Pinterest Ads Support and here is the latest:

"Thank you for bringing this to our attention. We've seen several occurrences of this error in our logs and are actively investigating. I'll follow up as soon as we have more details."

Fivetran Development Team will continue to follow up with Pinterest Support.
Posted Jul 09, 2020 - 18:44 UTC
This incident affected: Fivetran Services (API, Replication Servers).