Trouble Creating New Accounts
Incident Report for Fivetran Inc
Resolved
This incident has been resolved.
Posted Apr 26, 2020 - 17:59 UTC
Update
Our Engineering is continuing to work on a fix for this issue.
Posted Apr 26, 2020 - 01:38 UTC
Identified
We are currently facing issues with creating new accounts. We have identified the issue and are working towards a fix.
Posted Apr 25, 2020 - 10:23 UTC
This incident affected: Fivetran Services (Web App).