3rd Party: Some Salesforce Connectors Are Failing With 500 Internal Server Error

Incident Report for Fivetran

Resolved

The incident is now resolved. We've confirmed that instance rates have returned to normal, and all affected connectors are syncing as expected.

Incident Summary
Description:
We identified an issue for Salesforce connectors, which resulted in syncs failing with sync errors.

Cause: Salesforce Connectors were unable to sync the following objects:
- DataObjSecondaryIndexFeed
- DataObjSecondaryIndexHistory
- DataSemanticSearchFeed
- DataSemanticSearchHistory
- MarketSegmentActivationFeed
- MarketSegmentActivationHistory
- MktSgmtActvContactPtSrc

Resolution:
A temporary fix was implemented to bypass the failing tables in the sync process. We are actively collaborating with the Salesforce team to identify the root cause of their service disruption and will apply a permanent fix once it becomes available.

Update as of Sept 25, 2025 - 4:35 UTC:
Salesforce has identified this as a bug on their end and is actively working on a fix, which you can track here: https://help.salesforce.com/s/issue?id=a02Ka00000jhXbjIAE
Posted Sep 19, 2025 - 10:25 UTC

Update

The syncs are running successfully after the Hotfix, and we have not observed any failures. We are discussing this with Salesforce support to understand the root cause. The failing tables will be skipped until Salesforce releases a permanent fix.
Posted Sep 19, 2025 - 07:32 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 19, 2025 - 07:30 UTC

Update

The Hotfix to exclude the impacted tables is deployed, and we are currently monitoring the syncs.
Posted Sep 19, 2025 - 07:09 UTC

Update

We are continuing to observe connection failures with HTTP 503 errors from the Salesforce endpoint. Our team is actively working with Salesforce Support to investigate and resolve the issue.
In the meantime, as a temporary workaround, we are implementing a fix to exclude the impacted tables in Salesforce.
Posted Sep 19, 2025 - 05:19 UTC

Monitoring

After a call with Salesforce, our engineers believe the disruption on Salesforce Data Cloud (https://status.salesforce.com/) is the root cause of the issue, as the failing objects are part of the Data Cloud license. Salesforce has confirmed that a fix is being rolled out on their end.
Posted Sep 18, 2025 - 22:27 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Sep 18, 2025 - 19:25 UTC
This incident affected: Sales connectors (Salesforce).