This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.
Incident Summary
Description: We have identified an issue where new changes are not being captured for a subset of tables in PostgreSQL connectors utilising the Teleport update method.
Timeline: This issue began on 2025-10-20 00:00 UTC and was resolved on 2025-10-31 11:36 UTC.
Cause: The issue is confined to tables meeting specific structural criteria that hinder the Teleport update method's ability to capture new changes: Tables without a Primary Key (PKless tables). Tables with a Primary Key (PK) column of one of the following data types: real, double, timestamp, timestamptz, or bytearray.
Resolution: The engineering team identified the faulty logic and successfully rolled back the preceding changes. We subsequently initiated an automatic table-level resync for all affected data objects.
Posted Oct 31, 2025 - 13:54 UTC
Update
We have implemented a fix for approximately 75% of the impacted connectors. The fix is continuing to roll out to the remaining connections. Our team continues to closely monitor the rollout to ensure all connectors are fully restored.
Posted Oct 31, 2025 - 05:28 UTC
Update
Half of the impacted connectors have been fixed, and the fix will continue to roll out to the rest of the connections.
Posted Oct 31, 2025 - 00:40 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 30, 2025 - 17:38 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 30, 2025 - 17:08 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 30, 2025 - 11:59 UTC
Update
We are investigating an issue affecting a subset of tables in Postgres connections using the Teleport update method.
The impacted tables include those that:
- Do not have a primary key (PKless tables), or - Have a primary key column that is one of the following data types: real, double, timestamp, timestamptz, or bytearray.
For tables that meet the above conditions, new changes may not have been captured since October 20th. Previously ingested records remain available in the destination.
Our engineering team is actively investigating the root cause and working to restore normal data ingestion behaviour.
We will provide further updates as more information becomes available.
Posted Oct 30, 2025 - 01:35 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Oct 30, 2025 - 00:15 UTC
This incident affected: Database connectors (Amazon Aurora PostgreSQL, Azure Database for PostgreSQL, Google Cloud SQL for PostgreSQL, Heroku PostgreSQL, PostgreSQL, Amazon RDS for PostgreSQL).