Postgres syncs fail with "Unable to initialize table buffers"
Incident Report for Fivetran
Postmortem

The root cause was related to a multithreading feature which allows us to import new tables while at the same time keep up with incremental syncs. 

Our developers found that the state we save between syncs was not being saved correctly leading to this failure. The permanent fix for this will be put in place by the end of this week and we will remove the backup workaround only when we have successfully monitored connectors running successfully with only the long term fix in place.

Posted Oct 19, 2021 - 02:09 UTC

Resolved
All affected connectors have returned to normal.
Posted Oct 19, 2021 - 02:08 UTC
Monitoring
Engineering has the workaround in place and we are seeing the affected connectors begin to recover.

You can click the sync now button in the upper right corner of the connector dashboard to manually start an incremental sync instead of waiting for the next automatically scheduled sync.
Posted Oct 18, 2021 - 21:43 UTC
Update
We expect the workaround to be fully deployed in the next two hours.
Posted Oct 18, 2021 - 19:19 UTC
Update
We have deployed a workaround and are monitoring the results.
Posted Oct 18, 2021 - 18:40 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Oct 18, 2021 - 17:45 UTC