Fivetran: Amazon Ads connectors are failing with "java.lang.NullPointerException" while trying to fetch reporting tables

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that failure rates are returning to normal levels and affected connectors are syncing successfully.
Posted Oct 19, 2023 - 12:47 UTC

Monitoring

A hotfix has been deployed and connectors have started to recover.

We will continue to monitor all affected connectors until they resume their normal sync functionality.
Posted Oct 19, 2023 - 12:14 UTC

Identified

Our engineering team have identified the issue and are currently preparing the fix
Posted Oct 19, 2023 - 10:06 UTC
This incident affected: Marketing connectors (Amazon Ads).