3rd Party: Shopify connections are failing with a "HTTP 404 Not Found" error

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates have returned to normal levels, and affected connections are syncing successfully.

Incident Summary

Description:
We identified an issue where Shopify connections were failing with an HTTP 404 Not Found error.

Timeline:
The issue began on 2026-06-03 at 13:10 UTC and was resolved on 2026-06-03 at 15:00 UTC.

Cause:
The failures were caused by an issue on Shopify's side, which resulted in unexpected API error responses.
For more information, please refer to the Shopify Status Page: https://www.shopifystatus.com/incidents/gbqcx5fk01gz

Resolution:
No action was required from our side. The issue was resolved by Shopify, and affected syncs recovered automatically once the upstream issue was addressed.
Posted Jun 03, 2026 - 15:43 UTC

Monitoring

Update from Shopify: "We've identified the problem and are seeing recovery from our mitigation efforts. We will continue to monitor and update."

We are seeing that Shopify connector syncs are now recovering.

Next Expected Update: 3 hours
Posted Jun 03, 2026 - 15:16 UTC

Update

We are preparing a fix to skip the failing endpoints until Shopify resolves the issue.

Next Expected Update: 1 hour
Posted Jun 03, 2026 - 14:16 UTC

Update

Our requests to multiple Shopify API endpoints are failing with 404 errors.

There is an outage reported on the Shopify status page - https://my.shopifystatus.com/

Next Expected Update: 1 hour
Posted Jun 03, 2026 - 14:10 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Jun 03, 2026 - 13:55 UTC
This incident affected: Sales connectors (Shopify).