Some Mixpanel Connectors are failing with a "Read timed out" exception
Incident Report for Fivetran
Resolved
This incident has been resolved and the affected connectors have resumed their normal functionality.
Posted Jul 19, 2022 - 13:01 UTC
Monitoring
This partial outage looks to be linked to a source side outage for Mixpanel's data export pipelines. According to Mixpanle's Status Page (https://www.mixpanelstatus.com/incidents/00x0d99pjfp0), they have deployed a fix and are currently monitoring the situation.

There is still an export backlog on their side after the fix was deployed and as such, the result of their fix may not be visible immediately. We are currently monitoring all affected connectors in response to their fix.
Posted Jul 19, 2022 - 08:30 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Jul 19, 2022 - 08:18 UTC
This incident affected: Event connectors (Mixpanel).