Fivetran: Agent host field is missing in the setup form for private link HVA connectors.

Incident Report for Fivetran

Postmortem

Timeline in UTC:

2024-07-16 16:58 : Customer cannot create new Oracle HVA connector via private link because of missing Agent Host

2024-07-16 17:50 : Identified problem change that caused the issue.

2024-07-16 22:00 : Hot Fix is deployed.

2024-07-16 22:05 : Marked issue as resolved

Root Cause:

In attempting to roll out a new feature to allow customers to self provision private link connections, we inadvertently hid the Agent Host field for HVA connectors using private link but not yet using the self service private link connections. =

Future Prevention:

  • Add test to protect the agent host field if a connector is using private link, but has not yet been migrated to the self service private link feature.
Posted Jul 23, 2024 - 19:26 UTC

Resolved

The fix was deployed and the agent host field is back in the setup form.
Posted Jul 17, 2024 - 01:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2024 - 01:37 UTC

Update

We have located the problematic recent change and are reverting it now. Our current target for having this resolved is 9PM Pacific time.
Posted Jul 17, 2024 - 00:17 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Jul 17, 2024 - 00:02 UTC
This incident affected: Database connectors (High-Volume Agent Oracle, High Volume Agent Db2 for i, High-Volume Agent SQL Server, High-Volume Agent SAP ECC on Oracle, High-Volume Agent SAP ECC on Oracle with NetWeaver, High-Volume Agent SAP ECC on Db2 for i, HVA SAP ECC on SQL Server).