Fivetran: "Fivetran API: Triggering syncs on file connectors with no custom primary keys defined fail with error "doesn't have primary key defined".

Incident Report for Fivetran

Resolved

We have resolved this incident.
Posted Aug 20, 2024 - 19:57 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 20, 2024 - 19:57 UTC

Update

The hotfix has been tested, and we are working on deploying it to our production services.
Posted Aug 20, 2024 - 19:26 UTC

Update

File connectors that do not use custom primary keys are affected.

Our development teams are working on a hotfix.
Posted Aug 20, 2024 - 18:28 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Aug 20, 2024 - 17:52 UTC
This incident affected: Systems (General Services).