Fivetran: Some Xero connectors are failing with a "ResponseProcessingException" error

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates have returned to normal levels and affected connectors are syncing successfully.

Incident Summary
Description:
We identified an issue for Xero connectors which resulted in syncs failing with a "ResponseProcessingException" error.

Timeline:
This issue began on June 1st at 01:08 UTC and was resolved on June 1st at 14:30 UTC.

Cause:
Source changes to the API pagination method for several endpoints resulted in failed API calls.

Resolution:
The pagination method used for failing API calls was updated which allowed API calls to execute successfully.
Posted Jul 01, 2024 - 12:33 UTC

Monitoring

We have deployed a fix for this issue: the pagination method used for failing API calls has been updated and all affected connectors are starting to resume their normal sync functionality.

We will continue to monitor all affected connectors until incidence rates return to normal levels.
Posted Jul 01, 2024 - 10:46 UTC

Identified

Some Xero connectors are failing with "ResponseProcessingException" errors when attempting to sync data for the following endpoints:
- Invoices
- Contacts
- CreditNotes
- BankTransactions
- ManualJournals
- Payments
- PurchaseOrders
- Prepayments
- Overpayments

We have identified a source change in the pagination method used for these endpoints which is resulting in failed API calls. We are currently working on a fix for this issue and we will be in touch with some additional updates accordingly.
Posted Jul 01, 2024 - 01:08 UTC
This incident affected: Finance connectors (Xero).