sage intacct connectors are receiving null primary key for `company` table i.e. RECORDNO
Incident Report for Fivetran
Resolved
We have resolved this incident.
Posted Nov 17, 2021 - 21:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2021 - 18:21 UTC
Update
Sage Intacct team responded that RECORDNO field is now obsolete and removed from API response. In place of RECORDNO field Title or CompanyID could be considered as Primary Key.

We are continuing to work towards a resolution and Fivetran engineering team is currently working on a fix to modify the Primary Key field.

Thank you for your continued patience while we work on fixing this.
Posted Nov 17, 2021 - 10:59 UTC
Update
We are continuing to work with the Sage Intacct team to understand the root cause of this behavior. In the meantime, we have received confirmation that deselecting the COMPANY table will allow syncs to resume. Once a stable solution is in place, you can re-enable the COMPANY table from the Fivetran Schema tab.
Posted Nov 16, 2021 - 10:10 UTC
Update
We are continuing to work with the Sage Intacct team to understand the root cause of this behavior. In the meantime, we have received confirmation that deselecting the COMPANY table will allow syncs to resume. Once a stable solution is in place, you can re-enable the COMPANY table from the Fivetran Schema tab.
Posted Nov 16, 2021 - 01:36 UTC
Update
Engineering team identified that COMPANY endpoint is not receiving RECORDNO field through API response from source and Fivetran considers RECORDNO as a primary key. Missing primary key in API response is causing the PrimaryKeyContainsNull exception.

We are continuing to work with Sage Intacct to understand the possible causes. As a workaround, deselect the COMPANY endpoint on Schema Config to make the connector succeed.

Thank you for your continued patience while we work on fixing this.
Posted Nov 15, 2021 - 12:39 UTC
Update
We are receiving NULL primary key values from Sage Intacct for the RECORDNO field in the Company endpoint. We are continuing to work with Sage Intacct to resolve the underlying cause of this issue. In the meantime, engineering team is investigating potential workarounds that will mitigate the impact of this incident.
Posted Nov 15, 2021 - 11:02 UTC
Update
We are continuing to work towards a resolution to this issue. Thank you for your understanding.
Posted Nov 15, 2021 - 03:30 UTC
Update
We are still trying to identify potential workarounds for customers impacted by this issue while simultaneously working with Sage Intacct's Support team. Thank you for your continued patience.
Posted Nov 14, 2021 - 03:32 UTC
Update
We are continuing to work with Sage Intacct to resolve the underlying cause of this issue. In the meantime, we are investigating potential workarounds that will mitigate the impact of this incident.
Posted Nov 13, 2021 - 18:31 UTC
Update
We are receiving NULL primary key values from Sage Intacct for the RECORDNO field in the Company endpoint.
We are in contact with Sage surrounding this issue.
Posted Nov 13, 2021 - 11:29 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Nov 13, 2021 - 09:36 UTC