3rd Party: Some Quickbooks connectors are failing with a bad syntax error

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.

Incident Summary
Description:
We experienced an issue affecting some QuickBooks connectors, where syncs were failing when attempting to ingest data from the Account table with the following error:
"The request cannot be fulfilled due to bad syntax"

Timeline:
This issue began on June 17, 2025, at 06:00 PM UTC and was resolved on June 18, 2025, at 03:58 AM UTC.

Cause:
We encountered an issue where queries to fetch the QuickBooks Account table with WHERE conditions on the Id field caused the sync to get stuck. This was due to a problem on QuickBooks end.

Resolution:
We updated our sync logic to use MetaData.LastUpdatedTime instead of Id for pagination to avoid the issue with the Account table.
Posted Jun 18, 2025 - 07:00 UTC

Monitoring

We have applied a fix that improves the pagination parameters used when ingesting data for the Account table, which has allowed syncs to complete successfully. We will continue to monitor all affected connectors until they resume their normal sync functionality.
Posted Jun 18, 2025 - 00:11 UTC

Identified

We have identified an issue with our QuickBooks connectors where syncs are currently failing when attempting to ingest data from the Account table. We will continue to investigate and provide additional updates.
Posted Jun 17, 2025 - 21:54 UTC

Investigating

We are currently investigating an issue with our QuickBooks connectors that is causing some connectors to fail.
Posted Jun 17, 2025 - 19:37 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Jun 17, 2025 - 19:35 UTC
This incident affected: Finance connectors (QuickBooks).