Apple has introduced cryptography in their authentication flow, which has led to the connector no longer being able to sync your analytics reports. To ensure the majority of your data continues to flow smoothly, we have disabled affected analytics reports from your connector.
If you require the analytics report data, you can create a new second connector at this time. Simply follow the Add Connector Flow to create a new Apple App Store Connector, entering a unique connector name in the Destination Schema field as you complete the setup form. The two connectors will run in parallel without any issues. Here is the updated setup guide: https://fivetran.com/docs/connectors/applications/apple-app-store/app-store-connect-setup-guide
An email communication with further details has been sent to impacted customers. As we have a solution in place, the incident has been marked as 'resolved'.
Posted Oct 25, 2024 - 23:20 UTC
Update
The syncs are passing for the Apple App Store connector after disabling the analytics reports. We are continuing to work on this issue.
Posted Oct 24, 2024 - 05:19 UTC
Update
We have disabled the analytics reports from syncing, which is causing the rescheduling. Currently, the connector will only sync sales/finance reports.
Posted Oct 23, 2024 - 15:04 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 23, 2024 - 07:57 UTC
Identified
We are continuing to work on a fix for this issue.
Posted Oct 23, 2024 - 00:13 UTC
Investigating
We have identified a possible root cause, but further investigation is required. We are continuing to investigate the issue to identify a solution.
Posted Oct 22, 2024 - 16:21 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 22, 2024 - 07:15 UTC
Identified
Apple App Store connectors are being rescheduled due to failures in 2FA authentication. We will continue to investigate and provide additional updates.
Posted Oct 21, 2024 - 19:00 UTC
This incident affected: Marketing connectors (Apple App Store).