Some Hubspot Connectors are Failing
Incident Report for Fivetran
Postmortem

Issue

Some HubSpot connectors started failing with a 400 Bad Request error while making calls to the Ticket endpoint.

Root Causes and Complications:

A change by HubSpot caused connectors that hadn’t re-authorized their app since the Ticket endpoint was rolled out in November 2020 to start failing.

Resolution:

Disabled the Ticket endpoint from the Schema page in the dashboard and temporarily skipped syncing the Ticket endpoint, pending re-authorization. The informational tooltip next to the disabled Ticket endpoint will also inform users to perform re-authorization.

Posted Feb 02, 2021 - 20:21 UTC

Resolved
The fix is now live and the connectors are now running successfully. We will be sending out an email regarding the details of the fix soon.
Posted Jan 14, 2021 - 12:09 UTC
Monitoring
A fix has been deployed and we are starting to see connectors running successfully. We'll continue to monitor this.
Posted Jan 14, 2021 - 10:37 UTC
Identified
A recent update in the HubSpot API has been identified as the root cause. We are currently working towards a fix.
Posted Jan 14, 2021 - 02:04 UTC
Investigating
A number of Hubspot connectors have been failing with a 400 internal service error. We are currently working with Hubspot to investigating this issue.
Posted Jan 13, 2021 - 22:56 UTC