This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.
Incident Summary Description: We identified an issue for Twitter Ads which resulted in syncs failing with a "Null primary key found" error.
Timeline: This issue began on 2026-04-14 at 16:30 UTC and was resolved at 23:30 UTC.
Cause: Twitter API started returning null values in a primary key field (segment) for some reports, causing sync failures.
Resolution: Twitter resolved the issue within the source: https://devcommunity.x.com/t/x-api-service-outage/262778 A hotfix was deployed by Fivetran to prevent further failures by skipping keys where the primary key was not present.
A hotfix has also been deployed to prevent further failures due to null primary keys. We have observed connections begin to recover and will continue monitoring.
Posted Apr 14, 2026 - 22:48 UTC
Update
We have identified an issue where the source API is returning null values in a primary key field (segment) for some reports, resulting in sync failures.
We are actively working on a fix to skip these rows so that syncs can continue without interruption. We will provide another update as more information becomes available.
Posted Apr 14, 2026 - 19:21 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Apr 14, 2026 - 16:40 UTC
This incident affected: Marketing connectors (Twitter Ads).