3rd Party: Some Amazon Selling Partner connectors are failing whilst querying the FINANCIAL_EVENT_GROUP endpoint
Incident Report for Fivetran
Resolved
This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.
Posted Oct 26, 2023 - 14:53 UTC
Monitoring
We have deployed an additional fix for the failing FINANCIAL_EVENTS endpoint and have observed a large drop in connector sync failure rates.

We will continue to monitor affected connectors to ensure they resume their normal sync functionality.
Posted Oct 26, 2023 - 13:36 UTC
Update
We have successfully deployed a fix for the failing FINANCIAL_EVENT_GROUP endpoint and connectors are no longer failing when making this query. We have also observed some connectors are failing whilst querying the FINANCIAL_EVENTS endpoint and we are currently investigating these failures in more detail.
Posted Oct 26, 2023 - 11:26 UTC
Update
We have identified an issue with the Amazon Selling Partner connector caused by a change to the retention period for the financial event groups endpoint from the Amazon end without any prior notice.

The retention period for this endpoint has changed to 1 year (The data retention period went as far back as the year 2000 prior to this change). This is causing some connector syncs to fail with a "Bad Request" error whilst the connector is trying to fetch data outside of the new 1 year retention period.

Our developers have developed a fix for this which is currently under review. We will provide an additional update once the fix has been deployed.
Posted Oct 26, 2023 - 07:31 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Oct 26, 2023 - 07:09 UTC
This incident affected: Sales connectors (Amazon Selling Partner).