3rd Party: Hubspot connection syncs are failing with "HTTP 500 Internal Server Error" and message: "Your HubSpot source is not available at this time. We'll retry the sync later."

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connections are syncing successfully.

Incident Summary

Description:
We identified an issue with the HubSpot connection, which resulted in syncs failing with "HTTP 500 Internal Server Error"

Timeline:
This issue began on 8th May 2026 at 12:07 AM UTC and was resolved on 8th May 2026 at 01:32 AM UTC.

Cause:
The issue was caused by the third-party, event-definitions endpoint failing with "HTTP 500 Internal Server Error". HubSpot has also updated their status page, confirming the regional degradation due to the AWS outage.

Resolution:
The issue was automatically resolved from the third-party side without any intervention from the Fivetran end.
Posted May 08, 2026 - 03:25 UTC

Monitoring

Syncs are recovering, and we are monitoring the results.
Posted May 08, 2026 - 02:15 UTC

Update

HubSpot has updated their status page, confirming the regional degradation due to the AWS outage. We are also observing that sync failure rates are decreasing. We are monitoring the situation closely.

https://status.hubspot.com/incidents/f0s8vh3hsftw ("HubSpot is experiencing a regional degradation causing issues with loading related to an AWS outage")
Posted May 08, 2026 - 02:13 UTC

Update

Syncs are failing due to an issue on the third-party side, due to "HTTP 500 Internal Server Error" for the event-definitions endpoint.

At this time, there are no reported incidents or updates on the HubSpot status page related to this behaviour. We have reached out to HubSpot support for more details on these failures.

HubSpot status page link: https://status.hubspot.com/
Posted May 08, 2026 - 01:27 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted May 08, 2026 - 01:15 UTC
This incident affected: Sales connectors (HubSpot).