3rd Party: Twitter Ads and Twitter Organic connections are experiencing sync failures due to an HTTP 503 (Service Unavailable) error

Incident Report for Fivetran

Update

A hotfix will be deployed to handle 503 errors from the Twitter API and to skip failing endpoints after several retries.

We are still waiting for an update from X regarding the issue:
https://devcommunity.x.com/t/503-error-while-requesting-12-stats-jobs-accounts-accountid/262061
Posted Apr 07, 2026 - 21:50 UTC

Update

We’ve logged an issue with the Twitter support team and will share updates shortly.
Link: https://devcommunity.x.com/t/503-error-while-requesting-12-stats-jobs-accounts-accountid/262061
Posted Apr 07, 2026 - 17:23 UTC

Update

We have identified that the '/stats/jobs/accounts/' endpoint is returning HTTP 503 (Service Unavailable), impacting syncs.
Posted Apr 07, 2026 - 17:18 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Apr 07, 2026 - 16:30 UTC
This incident affects: Marketing connectors (Twitter Organic, Twitter Ads).