3rd Party: Multiple Twitter Ads connections failing due to 500 errors

Incident Report for Fivetran

Resolved

Incident Summary:

Description:

Multiple Twitter Ads connectors failed due to the Twitter Ads API returning persistent server errors (HTTP 500) on reporting endpoints.

Timeline (UTC):

Started at 25.04.2026 21:00 and Resolved 26.04.2026 11:50

Cause:

The Twitter Ads API experienced an outage, returning repeated HTTP 500 Internal Server errors on the stats reporting endpoint (POST URI https://ads-api.twitter.com/12/stats/jobs/accounts/).

Resolution:

Deployed a fix/workaround that enables the connector to gracefully handle HTTP 500 errors from the Twitter Ads API. Affected accounts are now skipped with a customer-facing warning on the connector dashboard, sync progress is preserved for successful accounts, and skipped data is automatically retried on the next sync.
Posted Apr 26, 2026 - 13:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 26, 2026 - 12:26 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 26, 2026 - 05:48 UTC

Update

We are receiving 500 Internal Server Errors from the Twitter API when querying the accounts endpoint.
Posted Apr 26, 2026 - 00:09 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Apr 25, 2026 - 22:55 UTC
This incident affected: Marketing connectors (Twitter Ads).