ERROR: remaining connection slots are reserved for non-replication superuser and rds_superuser connections
Incident Report for Fivetran
Postmortem

Timeline:

Started 7:58am Pacific Time.

Resolved 8:19am Pacific Time.

What happened?
There was a long-running query in our main production database that ran for an excessive amount of time and did not respect the deadline we have set for query times.

Resolution.

We killed the long running query which was using excessive system resources.

Next Steps.

Engineering will investigate the query which caused this to find why it did not automatically end at our defined query timeout.

Posted Apr 26, 2022 - 15:45 UTC

Resolved
Some connectors may have failed with the subject error: ERROR: remaining connection slots are reserved for non-replication superuser and rds_superuser connections, or the syncs would have been delayed for around 10 minutes.
Posted Apr 26, 2022 - 15:00 UTC