3rd Party: Snowflake Downtime Causing Sync Failures Across Multiple Connections Using Snowflake as Destination

Incident Report for Fivetran

Resolved

We have resolved this incident.
Posted Mar 21, 2026 - 10:30 UTC

Update

We are continuing to monitor to ensure all syncs return to normal.

More details: https://status.snowflake.com/
Posted Mar 21, 2026 - 09:38 UTC

Monitoring

Snowflake has reported recovery for US regions, and we are monitoring to ensure all syncs return to normal.

More details: https://status.snowflake.com/
Posted Mar 21, 2026 - 09:37 UTC

Update

Sync failures were caused by an ongoing Snowflake issue impacting Snowflake destinations. Snowflake has reported recovery for US regions, and we are monitoring to ensure all syncs return to normal.

More details: https://status.snowflake.com/
Posted Mar 21, 2026 - 07:07 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Mar 21, 2026 - 07:05 UTC
This incident affected: Systems (Destinations, General Services).