Apple App Store connectors were failing with Unknown failure. Cannot read field "endPeriodDate" because "fiscalDate" is null error.

Incident Report for Fivetran

Resolved

Incident Summary:

Description:
The Apple App Store connectors started failing with the Unknown failure. Cannot read field "endPeriodDate" because "fiscalDate" is null
error.

Timeline:
Issue started at 12:00 AM UTC and ended 12:00 PM UTC.

Cause:
This issue was caused due to new fiscal year for finance report had started today and the connector was not designed to handle this event.

Resolution:
We resolved the issue by making the necessary changes to handle the fiscal year calendar per iTunes.
Posted Sep 28, 2025 - 15:07 UTC