Fivetran: Multiple Amazon S3 Connections Failing Setup Tests with RefreshCredentialsException

Incident Report for Fivetran

Resolved

This incident has been resolved. Instance rates are returned to normal levels, and affected connectors are syncing successfully.

Description:
Multiple Amazon S3 Connections Failing Setup Tests with RefreshCredentialsException

Timeline:
This issue began on September 17,2025, at 3:00 PM UTC and was resolved on September 18,2025, at 12:15 AM UTC.

Cause:
The issue was caused by a bug introduced in a recent code change.

Resolution:
We resolved the issue by rolling back the change, which restored normal functionality.
Posted Sep 18, 2025 - 01:20 UTC

Update

We are continuing to monitor the connections.
Posted Sep 18, 2025 - 00:42 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 18, 2025 - 00:10 UTC

Update

We have identified the issue and are working to resolve it.
Posted Sep 17, 2025 - 21:43 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Sep 17, 2025 - 21:40 UTC
This incident affected: File connectors (Amazon S3).