Fivetran: Several Stripe connectors got re-scheduled with "java.lang.NullPointerException"

Incident Report for Fivetran

Resolved

Issue Summary:

Description:
Several connectors marked re-scheduled due to the null pointer exception because of the problem with the connector syncing connected accounts data.

Timeline:
Started 12 AM UTC until 3 PM UTC

Cause:
Recent internal change to the logic to sync the connected accounts data due to data integrity observed recently, there was a problem checking if the connected accounts sync is enabled.

Resolution:
A fix has been implemented to handle this use case that helped connectors to sync normally.
Posted Sep 13, 2025 - 16:05 UTC

Monitoring

We have deployed fix for the issue while the cause is the recent internal change to the logic to sync the connected accounts data due to data integrity observed recently. We are now monitoring the syncs.
Posted Sep 13, 2025 - 14:38 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Sep 13, 2025 - 13:15 UTC
This incident affected: Finance connectors (Stripe).